LetsEncrypt Frage

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • LetsEncrypt Frage

      Guten Tag,


      ich wollte gerne mal wissen ob es irgendwie möglich sei ein SSL Zertifikat von LetsEncrypt in eine EasySCP Domain einzufügen ?.

      Ich weiß das es hierzu ein Thema schon gibt, aber vielleicht gibt es ja jetzt eine Lösung dafür.


      Mit Freundlichen Gruß
    • Hallo,
      ich hänge mich mal hier ran denn ich stehe genau vor derselben Problematik.
      Für die Domain habe ich SSL Unterstützung im Panel aktiviert.
      Letsencrypt Einrichtung mittels Cerbot klappte (habe Secure gewählt = alle http Aufrufe auf https umleiten).

      Nur leider erscheint beim Aufruf der Domain der folgende Text, obwohl das Zertifikat angezeigt wird.
      Wo ist mein Denkfehler?

      Meldung:

      ***
      The Domain XXXXXX is disabled.

      Please get in contact with your Reseller for more information.
      ***

      Gruß Vin
    • Also die Domain ist mittels http erreichbar und aktiv.

      Ich nutze Debian 8 und habe das neueste EasySCP mittels SSH und anschließendem GUI Setup wie in der Anleitung ohne Probs installiert
      Basic Setup for EasySCP 2.0.0 on Debian

      Muss seitens easyscp die SSL Unterstützung aktiv oder inaktiv sein damit cerbot von letsencrypt einwandfrei die Config schreiben kann?
      Eine der Domains um die es geht lautet bfehrmann.de/

      Ich dreh mich gedanklich irgendwie im Kreis und finde keinen Ansatz. Danke für eure Unterstützung

      The post was edited 1 time, last by vin ().

    • Hi,

      LetsEncrypt sollte die Apache Config bei EasySCP nicht schreiben, da er diese schlicht nicht korrekt neu schreiben kann. Dadurch kommt es dann zu Problemen. Dafür bieter LetsEncrypt ja die Möglichkeit das man die Zertifikate separat speichern kann. Anschließend kannst du diese dann per Panel installieren.

      Auf deinem System müsste man jetzt erst mal prüfen wie die aktuelle Apache Konfiguration aussieht, und dieses dann korrigieren, damit alles so läuft wie erwartet.
      Gruss
      Shadow
    • Hi,
      Das hatte ich fast vermutet. Mist.
      Tja mein Problem ist das ich mich nicht gut mit den Diensten auskenne :(
      Wo jetzt was stehen müsste kann ich nicht unterscheiden.
      Ich wollte das System eigentlich nicht nochmal aufsetzen müssen.
      Hast du evt einen Tipp wo ich ansetzen kann?

      Gesendet von meinem LG-H815 mit Tapatalk
    • Wird durch einen Cronjob im Panel (Zertifikat auto renew = LetsEnCrypt alle 3 Monate) das Zertifikat im Panel aktualisiert?
      oder im Filesystem was ein Kopieren alle 3 Monate bedeuten würde, oder liege ich falsch?

      The post was edited 1 time, last by vin ().

    • Hi,

      ich habe jetzt leider auch den gleichen Fehler gemacht und Let's Encrypt automatisiert über Certbot installiert.
      Anschließend kam auch erstmal der Fehler "The Domain XXXXXX is disabled.Please get in contact with your Reseller for more information.".

      Nachdem ich das Zertifikat in EasySCP hinzugefügt habe, wurde die HTTP Seite weitergeleitet auf die HTTPS Seite und man kam gar nicht mehr auf die Website. Ich habe es jetzt auch nach mehreren Stunden nicht geschafft, den Fehler zu finden. Nachdem ich das Zertifikat in EasySCP wieder gelöscht habe, kam ich wieder auf die HTTP Seite.

      Nun weiß ich nicht mehr weiter. Könntest du vielleicht auch bitte meine Dateien anschauen, ob du etwas findest?


      Viele Grüße

      Niklas
    • Hi,

      das anlegen über die Oberfläche ist sicherlich immer die beste Wahl. Dann ist sichergestellt das die Apache Konfiguration die passenden SSL Einträge enthält.

      Das reine hinzufügen der SSL Zertifikate zur normalen Konfiguration sorgt ansonsten für ärger, da üblicherweise auf Port 80 unverschlüsselt übertragen wird. Auch fehlen die sonstigen Einstellungen welche die HTTP von der HTTPS Verbindung/Konfiguration unterscheiden.

      Nur weil man bei einer reinen HTTP Konfiguration die Zertifikate hinzufügt wird daraus eben noch keine HTTPS Konfiguration. Daher auch die Fehlermeldungen bei dir, plus die falschen Konfigurationen die da noch mit im Apache Ordner waren. Ich habe die alle gelöscht damit das System bei dir wieder fehlerfrei läuft.
      Gruss
      Shadow
    • Ich habs mein mir so gemacht:
      - Zertifikat einmalig über die Oberfläche einbinden, sodass die Einträge im Apache angelegt werden.
      - Symlink von den von Easyscp angelegten Dateien in /etc/ssl auf die von LetsEncrypt in /etc/letsencrypt/live/. Das selbe auch für Postfix und Dovecot.
      - Alle 3 Monate einfach ein certbot-auto renew ausführen um das ganze System mit neuen Zertifikaten zu versorgen. Vorher Apache, Dovecot und Postfix stoppen.
      Funktioniert einwandfrei. Könnte man dann ja auch vollautomatisch als Crontab eintragen.
    • Hi Lotusbluemchen,

      vielen Dank für deine Ideen!
      Ich habe es genauso gemacht, also CertBot als standalone Version gestartet, Zertifikate ausstellen lassen und dann eingebunden nach deiner Beschreibung.
      Dann habe ich mir noch ein Skript gebastelt, dass nun einmal im Monat, nachts den CertBot rennen lässt und die Zertifikate erneuert:

      Shell-Script

      1. #!/bin/bash
      2. /bin/echo "stopping all needed services..."
      3. /usr/sbin/service apache2 stop
      4. /bin/echo "renewing all certs..."
      5. /usr/bin/certbot renew
      6. /bin/echo "starting and restarting all services..."
      7. /usr/sbin/service apache2 start
      8. /usr/sbin/service dovecot restart
      9. /usr/sbin/service postfix restart

      Der CertBot macht den Rest, denn in der Konfig ist eingetragen, dass er erst 30 Tage vor ablauf das Zertifikat erneuert.
      Wenn jemand noch einen Tipp hat es besser zu machen, nur her damit! - Man ist ja lernwillig ;)

      Gruß
      piccolo