Debugger problem

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Debugger problem

      Hallo

      Nutz EasySCP 2.0.2

      und nun hab ich da ein Problem mit den Domaain's löschen
      Debugger bekomme ich die Meldung : socket_connect() failed.
      wie kann ich das Problem bitte lösen.
      ich danke schon mal dafür

      Gruß Blacky
      Images
      • Eayscp02.png

        52.69 kB, 1,086×668, viewed 52 times
      • Eayscp01.png

        34.18 kB, 1,086×668, viewed 48 times
    • Hier mal die Logdatei /var/log/easyscp/easyscp_daemon.log :
      [Apr 30 18:21:57] info: Client connected
      [Apr 30 18:21:57] info: Running DaemonDomain subprocess.
      [Apr 30 18:21:57] info: Finished DaemonDomain subprocess.
      [Apr 30 18:21:57] info: Closing connection.
      [Apr 30 18:21:57] info: Client connected
      [Apr 30 18:21:57] info: Running DaemonMail subprocess.
      [Apr 30 18:21:58] info: Finished DaemonMail subprocess.
      [Apr 30 18:21:58] info: Closing Connection.


      Leider ist wieder eine Domain die ich nicht bearbeiten lässt

      hab auch wieder den Befehl ( /etc/init.d/easyscp_daemon start ) gemacht aber leider ohne erfolg diesmal
      hier die Logdatei von heute :
      [May 08 13:00:46] info: Client connected
      [May 08 13:00:46] info: Running DaemonMail subprocess.
      [May 08 13:00:46] info: Delete Mail User Directory /var/mail/virtual/****************/webmaster
      [May 08 13:00:46] info: Delete Mail User Directory /var/mail/virtual/***************/postmaster
      [May 08 13:00:46] info: Delete Mail User Directory /var/mail/virtual/***************/abuse
      [May 08 13:00:46] info: Finished DaemonMail subprocess.
      [May 08 13:00:46] info: Closing connection.
      [May 08 13:00:46] info: Client connected
      [May 08 13:00:46] info: Running DaemonDomain subprocess.
      [May 08 13:00:47] info: SQLSTATE[42S02]: Base table or view not found: 1109 Unknown table 'domains' in MULTI DELETE
      [May 08 13:00:47] info: Closing connection.
      [May 08 13:01:07] info: Client connected
      [May 08 13:01:07] info: Running DaemonCore subprocess.
      [May 08 13:01:07] info: Finished DaemonCore subprocess.
      [May 08 13:01:07] info: Closing connection.
      [May 08 13:01:14] info: Client connected
      [May 08 13:01:14] info: Running DaemonCore subprocess.
      [May 08 13:01:14] info: Finished DaemonCore subprocess.
      [May 08 13:01:14] info: Closing connection.
      [May 08 13:01:21] info: Client connected
      [May 08 13:01:21] info: Running DaemonCore subprocess.
      [May 08 13:01:21] info: Finished DaemonCore subprocess.
      [May 08 13:01:21] info: Closing connection.
      [May 08 13:01:31] info: Client connected
      [May 08 13:01:31] info: Running DaemonCore subprocess.
      [May 08 13:01:32] info: Finished DaemonCore subprocess.
      [May 08 13:01:32] info: Closing connection.
      [May 08 13:04:21] notice: Starting easyscp_daemon daemon, output in: '/var/log/easyscp/easyscp_daemon.log'
      [May 08 13:04:21] emerg: easyscp_daemon daemon is still running. Exiting [l:1319]
      [May 08 13:04:21] info: Process was not daemonized yet, just halting current process
      [May 08 13:04:59] info: Client connected
      [May 08 13:04:59] info: Running DaemonCore subprocess.
      [May 08 13:04:59] info: Finished DaemonCore subprocess.
      [May 08 13:04:59] info: Closing Connection.
    • Hi,

      dann mache mal bitte folgendes:

      Zuerst den Daemon stoppen,

      Source Code

      1. /etc/init.d/easyscp_daemon stop

      danach in der Datei "/etc/easyscp/EasySCP_Config.xml" den Eintrag "DEBUG" auf "1" setzen und den Daemon wieder starten


      Source Code

      1. /etc/init.d/easyscp_daemon start

      Und dann hätte ich gerne das Log das er dann erzeugt per PN. Dort stehen dann die DEBUG Ausgaben zusätzlich mit drinnen, dann kann ich mir das anschauen.
      Gruss
      Shadow
    • Hi,

      du hast nur das Log geschickt, bis zu dem Zeitpunkt wo du den Daemon neu beendest/startest. Ich brauche aber das log, wenn du mit aktivem DEBUG Modus den Request aus der GUI nochmals ausführen lässt, damit man sieht wo er stehen bleibt. Solange du den Request nicht aus der "GUI -> EasySCP Debuuger" ausführen lässt, solange steht im Log auch logischerweise keine DEBUG ausgaben, da der Daemon ja solange nichts tut.
      Gruss
      Shadow
    • Hi,

      keine Ursache.

      Das Problem ist wohl ein Logik Fehler. Ich muss das mal neu sortieren, da er auch dann den User löscht wenn beim löschen der Domain ein Fehler aufgetreten ist. Danach kann die Domain dann nicht mehr aus dem Panel heraus gelöscht werden.

      Das muss wie gesagt neu sortiert werden, damit er bestimmte Schritte erst dann ausführt, wenn andere erfolgreich abgeschlossen wurden.
      Gruss
      Shadow