EasySCP 2.1.0 Release Candidate

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • EasySCP 2.1.0 Release Candidate

      Hi,

      nach langem Gesuche habe ich dann endlich Postfix zum laufen bekommen:

      in der /etc/postfix/main.cf fand ich folgendes:


      Source Code

      1. myhostname = mail.mein-server.de.
      2. mydomain = mail.mein-server..local


      da haben sich 2 Punkte eingeschlichen, ich weiß aber nicht wo die herkommen, es sei denn, der FQDN wurde richtig mit abschliessendem . geschrieben ;) , dann ist der FDQN zwar richtig, hier ist es aber zu viel.

      Ansonsten: Danke für EasySCP, jetzt fehlt nur noch Roudcube, das macht zicken.... ich bin aber noch am googlen...
    • Hi,

      prinzipiell ist es per Definition zwar richtig das zwischen dem s.g. root-label und der Top-Level-Domain noch ein Punkt kommt. Da dass root-label aber sowieso nur eine leere Zeichenkette ist, ist es aus Anwender Sicht "richtig" und üblich das auch so (also ohne den Punkt am Ende) einzugeben. Ich kenne eigentlich niemanden der "www.google.com." schreibt ;)

      So was kenne ich eigentlich zwangsweise eher nur von DNS Einträgen. Von daher bin ich da jetzt auch überrascht, da ich so was selber noch nicht gesehen habe (außer eben bei DNS Konfigurationen).

      Mal schauen ob die PHP Prüffunktion bzgl. Domain Name da noch was hergibt. Ansonsten muss man das noch einbauen, das (falls vorhanden) der letzten Punkt entfernt wird.
      Gruss
      Shadow
    • Hi,

      naja, das mit dem FQDN ist ja uch echt "schwierig".
      Er wird verlangt, man liest an zig Stellen nach und kommt dann zu dem Schluß: es ist mit End-.
      Ich galube auch, dass hier das postfix-script dazwischen kloppt und nicht Dein Inst-Script. Aber wenn Du es prüfen kannst, dann wäre das natürlich toll.

      And now something complete different:
      SSL!

      Ich habe mir ein echtes Cert (COMODO) ausgestellt und im Backend für den Server installiert. Das ging noch.
      Dann habe ich auf "BOTH" gestellt - vorerst als safety, falls irgendwas dann nicht geht - und dann: nichts geht mehr - apache startet nicht mehr, Fehler:

      Source Code

      1. unable to configure verify locations for client authentication
      OK, zum Glück eine VM, also weg damit, Backup wieder eingespielt und dieses Mal NUR SSL aktiviert -> Läuft.

      Dieser Fehler ist in sofern interessant, weil was passiert, wenn die die virtuellen Domains auf "BOTH" stelle.

      Gruss, Kuerbis42

      PS: bekommst gleich noch eine PM zu diesem Thema
    • Ach bin ich heute aktiv ;)

      So, alles nochmal neu, weil wenn man da drin soviel rumschrabt, dann ist irgendwann "vorbei". Nun also der aktuelle Stausbericht und "echte Schwierigkeiten" mit 2.1.0:

      System-Infos: VM Maschine als LXC Container mit Debian 9 (strech), Pakete wie durch EasySCP vorgegeben (php7, mariadb, etc)

      1. ein echter wget-Pfad zur aktuellen Version wäre toll
      2. Nach der erfolgreichen Installation aller Pakete (-> Basic Setup EasySCP 2.0.0) und dem Versuch im Browser weiter zu machen (YOUR-DOMAIN/setup) fällt man in das MySQL
      easyscp can't connect sql - Loch! Abhilfe schafft hier folgendes im Terminal (ich schreibe das extra hier nochmal hin, weil ich wieder 30 Minutne gesucht habe, bitte Basic Setup darum ergänzen)

      Source Code

      1. mysql -u root -p
      2. UPDATE mysql.user SET plugin = 'mysql_native_password' WHERE user = 'root' AND plugin = 'unix_socket';
      3. FLUSH PRIVILEGES;

      3. Postfix:
      Es sollte nochmal explizit darauf hingwiesen werden, dass der FDQN NICHT der Maschinen-Name ist (also bei POSTFIX "www.meine-domain.de" nur "meine-domain.de" eingeben, UND das der letzte (egtl. richtige) . (Punkt) NICHT gesetzt wird.

      4. An dieser Stelle könnte man schon einmal die Website dnsstuff - DNS-Tools besuchen (Beispiel:dnsstuff.com/tools#dnsReport|type=domain&&value=meine-domain.de)
      Dann bekommt man schon einmal eine Übersicht was nicht richtig ist (z.B. fehlt der Mail-User "abuse", einzutragen in der /etc/aliases)

      weiter mit:
      5. Setup der GUI (also meine-domain.de/setup): Welcher Wert soll denn bei UTC hin? Vllt. ein kleines Beispiel oder Dropdown hier)

      Setup ist durchgelaufen:
      5. Update auf SSL (so dass EasySCP also mit HTTPS läuft), WICHITG!! In der Auswahl "SSL enabled", "SSL disabled","Both" NICHT auf "Both" stellen, sondern entweder an oder aus.
      6. Wenn SSL läuft, dann gibt es beim Anlegen einer Domain einen Redirection-Error (/reseller/user_add3.php) (Fehler: Gesicherte Verbindung fehlgeschlagen), zum Glück funktioniert "nochmal versuchen" + "erneut senden".

      7. Sehe gerade: Die "Alternative Website-URL" ist falsch, oder soll es so sein?!? http://vu2001.www.meine-domain.de (mit ohne www. wäre es ja OK)


      8. Anmeldung des "neuen Benutzers": komischerweise geht das Login nicht, erst nach Server-Reboot (vorher mal nur den easyscp-daemon neu gestartet, hilft nicht)

      9. roundcube: beim Versuch der Anmeldung: weisse Seite: meine-domain.de/webmail/?_task=login, nach <F5> "Ihre Sitzung ist ungültig oder abgelaufen."



      10: Das Package php7.0-zip fehlt...



      11. Wunsch für das nächste Release: fail2ban als Paket mit rein, es ist ja fürchterlich wer da alles rein will, zum Glück ist der root-login disabled ba debian.


      So, Feierabend, hoffe es hilft weiter.

      The post was edited 2 times, last by kuerbis42 ().

    • ROUNDCUBE

      Ich habe jetzt roundcube mit der Version 1.2.6 ersetzt und es läuft (bisher). D.h. ich konnte mich mit "alten" Userdaten (aus der Version 1.0.9, erzeugt durch EasySCP) einloggen und kann auch Mails verschicken.
      Soll ich dazu mal ein keines HowTo verfassen?
      Das Upgrade dauert inkl. allem ca. 15 Minuten - dann mußt Du -> Shadow, nicht lange im alten RC rumsuchen, warum das nicht geht.

      Gruss, Kuerbis42
    • Hi,

      erst mal danke für die Mühe die du dir gemacht hast. Bzgl. der MariaDB/MySQL Problematik: Die Anleitung ist ja auch für die 2.0.0. Dementsprechend ist es ja nur "logisch" das es dort "fehlt". Ich hatte schlicht noch keine Zeit eine neue für die 2.1.0 zu machen. ;(

      Bzgl. Postfix: Der mailname wird bei der Installation von Postfix automatisch korrekt von hostname übernommen, vorausgesetzt das System wurde sauber installiert. Und dieser ist tatsächlich xxx.domain.tld, ansonsten währe es kein FQDN. "domain.tld" ist eben kein gültiger FQDN, und sorgt nur dafür das du später massiv Probleme beim Versenden hast. Hier liegt leider oft das Problem das entweder die ISP´s unsaubere VMs an die Kunden verteilen mit "example.com" und ähnlichem Zeug im Image, das die wenigsten korrekt ersetzen. Oder aber das die Images korrekte saubere FQDN´s haben, aber jeder meint er muss diese ändern. Schlussendlich ist es im Grunde egal ob der Server als FQDN "server12345.anbieter.tld" hat, solange diese richtig und gültig sind. Meine Erfahrung zeigt das hier der größte Fehler liegt, da die wenigsten einen "echten" FQDN erzeugen können, aber viele denken sie müssten für den Server unbedingt "wunschname.tld" benutzen. Das ist aber wie oben geschrieben eben KEIN FQDN, sondern lediglich ein DN.

      Bzgl. SSL: Kann ich nicht nachvollziehen, ich kann wahlweise alle drei Varianten nehmen ohne Fehler. Ich teste das am Wochenende nochmals in aller Ruhe.

      Bzgl. RoundCube: Hier scheint es wohl tatsächlich so zu sein das es mit PHP7 zusammenhängt. Ich prüfe ob wir das direkt selber patchen können, den eigentlich ist es so das in PHP7 zwar Neuerungen drinnen sind, aber nichts weggefallen ist im Vergleich zu 5.6. Sagt zumindest Zend Technologies, sprich die sagen was mit 5.6 lief, läuft auch unter 7.0. Muss ich aber wie gesagt nochmal genau anschauen. Prinzipiell könnten wir das auch austauschen, aber dann läuft das nicht mehr mit CentOS. Also die neue Version läuft da nicht mehr.

      Ich sehe es schon kommen das ich die Tage getrennte Versionen für Debian ab Version 9 und CentOS raus bringen muss
      Gruss
      Shadow
    • ShadowJumper wrote:


      Bzgl. Postfix: Der mailname wird bei der Installation von Postfix automatisch korrekt von hostname übernommen, vorausgesetzt das System wurde sauber installiert. Und dieser ist tatsächlich xxx.domain.tld, ansonsten währe es kein FQDN. "domain.tld" ist eben kein gültiger FQDN, und sorgt nur dafür das du später massiv Probleme beim Versenden hast. Hier liegt leider oft das Problem das entweder die ISP´s unsaubere VMs an die Kunden verteilen mit "example.com" und ähnlichem Zeug im Image, das die wenigsten korrekt ersetzen. Oder aber das die Images korrekte saubere FQDN´s haben, aber jeder meint er muss diese ändern. Schlussendlich ist es im Grunde egal ob der Server als FQDN "server12345.anbieter.tld" hat, solange diese richtig und gültig sind. Meine Erfahrung zeigt das hier der größte Fehler liegt, da die wenigsten einen "echten" FQDN erzeugen können, aber viele denken sie müssten für den Server unbedingt "wunschname.tld" benutzen. Das ist aber wie oben geschrieben eben KEIN FQDN, sondern lediglich ein DN.
      Ja, es ist ein Elend mit dem FQDN - zum Glück kann ich "alles".
      Ich habe es ja mit einem richten (echten, zulässigen) FQDN gemacht - leider bekomme ich dann aber Mails von z.B. webmaster@scp.meine-domain.de
      Will ich aber nicht so haben - schließlich ist es ja eine Email vom DN-Webmaster.

      In diesem Zusammenhang steht dann natürlich auch der Punkt 7:

      kuerbis42 wrote:

      7. Sehe gerade: Die "Alternative Website-URL" ist falsch, oder soll es so sein?!? vu2001.www.meine-domain.de (mit ohne www. wäre es ja OK)
      Also irgendwie scheint sich die Welt da noch nicht richtig einig zu sein, oder stehe ich auf dem Schlauch?

      Gruss, Kuerbis
    • Hi,

      kuerbis42 wrote:

      Ja, es ist ein Elend mit dem FQDN - zum Glück kann ich "alles".Ich habe es ja mit einem richten (echten, zulässigen) FQDN gemacht - leider bekomme ich dann aber Mails von z.B. webmaster@scp.meine-domain.de
      Will ich aber nicht so haben - schließlich ist es ja eine Email vom DN-Webmaster.

      also ich habe mich bisher nicht wirklich darum gekümmert muss ich zugeben. Auch weil ich es persönlich nützlicher fand direkt zu sehen von welchem Server die Mail kommt. Außerdem konnte ich so schneller unterscheiden ob die Mail von einer Web Applikation kommt oder eben direkt vom Server selber. Kann man aber sicherlich einstellen, hat mich bisher nur eben selber nicht gestört weil ich es so angenehmer fand.

      kuerbis42 wrote:

      In diesem Zusammenhang steht dann natürlich auch der Punkt 7:

      kuerbis42 wrote:

      7. Sehe gerade: Die "Alternative Website-URL" ist falsch, oder soll es so sein?!? vu2001.www.meine-domain.de (mit ohne www. wäre es ja OK)
      Also irgendwie scheint sich die Welt da noch nicht richtig einig zu sein, oder stehe ich auf dem Schlauch?
      Gruss, Kuerbis
      Also ich habe das nirgendwo mit "www". Mir scheint das dort beim Installieren des Servers der FQDN mit www angegeben wurde. Weil die alternative URL ist immer vuxxxx.FQDN, so wie bei der Installation angegeben, also z.b. vu2001.scp.domain.tld.

      Das macht ja auch keinen Sinn. Man kann dann ja auf dem gleichen Server keine Webseite unter "www.domain.tld" mehr laufen lassen weil diese Adresse dann bereits vom Panel selber benutzt wird. Nicht ohne Grund benutzen die meisten Hosting Anbieter bei den Servern irgendwas mit "server12345.anbieter.tld". Das ist nicht nur praktischer für Sie selber in der Verwaltung, sondern verhindert auch ziemlich effektiv das dieser FQDN mit einem der "normalen" kollidiert und damit beim Kunden Probleme verursachen könnte wie z.b. domain.tld, mail.domain.tld, ftp.domain.tld, imap.domain.tld, pop3.domain.tld, smtp.domain.tld, etc.
      Gruss
      Shadow
    • Sorry, war jetzt natürlich etwas durcheinander - ich habe das Ding ja schon 3x aufgesetzt.

      Also: Beispiel Konfig mit scp.domain.tlp als FQDN

      Source Code

      1. $> hostename
      2. scp
      3. $> hostname -f
      4. scp.domain.tld



      Dann ergibt sich bei postfix: /etc/postfix/main.cf

      Source Code

      1. ....
      2. myhostname = scp.domain.tld
      3. mydomain = domain.tld.local
      4. myorigin = $myhostname //scp.domain.tld
      5. ...
      Emails vom Webmaster lauten dann: webmaster@scp.domain.tld


      In EasySCP sind die alternativen URLs dann z.B: vu2001.scp.domain.tld

      Beim 3. Aufsetzen habe ich dann als FQDN www.domain.tld gewählt (und nicht mehr scp, hängt mit dem Zertifikat zusammen, ich bekomme ein Zertifikat für www. domain.tld & domain.tld, sonst hätte ich ein Wildcard (teuer) nehmen müssen.
      Somit ergeben sich dann die entsprechenden URLs bzw. Email-Adressen. Aber webmaster@www. domain.tld sieht ja nun völlig bescheuert aus. (das Leerzeichen hinter www. , weil der Editor hier sonst zickt)

      Ich habe mir in meinem NS folgende Wildcard gesetzt: *.www IN A 199.199.199.199 (die IP ist Bsp.!)
      Damit klappt dann www. domain.tld als "allgemeine" Adresse für's SCP, und die vuXXXX.www.domain.tld werden auf die richten Seiten weitergeleitet, bzw. vom Apache umgesetzt.

      In der /etc/postfix/main.cf habe ich den Eintrag "myorigin" manuell auf domain.tld geändert. Außerdem habe ich noch mydestination angepaßt, sonst kommen nicht alle Mails intern an.

      Nach abgeschlossener Installation und meinen Änderungen sieht meine /etc/postfix/main.cf jetzt so aus:


      Source Code

      1. ....
      2. myhostname = www.domain.tld
      3. mydomain = domain.tld.local
      4. # myorigin = $myhostname
      5. myorigin = domain.tld
      6. # Receiving messages paramters
      7. mydestination = $myhostname, $myorigin, $mydomain, localhost
      8. ....



      CUT.

      The post was edited 6 times, last by kuerbis42: optische Verbesserung ;-) ().

    • Und gleich dazu noch eine Frage, weil jetzt bekomme ich ein anderes Problem:

      Ein Kunde hat seinen Email-Server (Exchange) natürlich nicht auf meinem Server laufen, sondern betreibt ihn selbsttätig. Die Webprogrammierer sind aber nicht in der Lage mit dem Windows-Server eine Website zubauen (sag ich nichts zu). Nun ist also die www. bei mir auf dem Server, die Email Adressen aber auf einem anderen Server.

      Wie kann ich das postfix klar machen? Ich bin der Meinung das bei EasySCP mal eine Einstellung für andere Mail-Server eingebaut war, ich finde es aber nicht mehr.

      Weil sonst kommen meine Mails an den Kunden nicht an, denn mein Server versucht die Mails ja intern zuzustellen, von extern her funktioniert ja alles wie gewohnt.

      Da wäre ein Tipp noch super.
      Danke,
      Gruesse, Kuerbis
    • Hi,

      das mit dem Zertifikat kann ich nicht nachvollziehen, da man diese mittlerweile Gratis bekommen kann für jeden Server, somit stellt xyz.domain.tld kein Problem dar.

      Bzgl. Postfix: Viele Mailserver nehmen deine Mails aber nicht an, wenn in Postfix nur ein DN und kein FQDN konfiguriert ist. Somit nützt es schlussendlich dann wenig wenn die Mails dann "schöner" aussehen, weil sie jetzt von "webmaster@domain.tld" kommen, und dafür Google und Co. deine Mails nicht mehr annehmen weil du keinen FQDN benutzt. Möglicherweise kann man das separat irgendwo ändern, so das Postfix den FQDN für seine Dienste nutzt, und nur als Absender eine andere Adresse. Weiß ich aber aktuell nicht, da ich es wie gesagt bisher nicht gebraucht habe.

      Bzgl. dem externen Mail Server: Beim Anlegen des Kunden musst du die Mail Adressen auf "-1" setzen, dann wird Postfix auch nicht für diese Domain konfiguriert. Nachträglich kannst du das ändern, indem du zum einen die Mail Accounts und die Domain in der mail.domains bzw. mail.users löschst. Und dann noch im Lokalen DNS den MX Eintrag der Domain auf die tatsächliche IP des externen Servers umstellst. Dann passt das.
      Gruss
      Shadow
    • ShadowJumper wrote:



      Bzgl. dem externen Mail Server: Beim Anlegen des Kunden musst du die Mail Adressen auf "-1" setzen, dann wird Postfix auch nicht für diese Domain konfiguriert. Nachträglich kannst du das ändern, indem du zum einen die Mail Accounts und die Domain in der mail.domains bzw. mail.users löschst. Und dann noch im Lokalen DNS den MX Eintrag der Domain auf die tatsächliche IP des externen Servers umstellst. Dann passt das.

      Danke für den Tipp. Es hat geklappt aber:
      trotz "Mail Adressen = -1" legt EasySCP die Standartadressen "webmaster","abuse", und "postmaster" an und trägt die Domain auch in der Tabelle mail.domains ein.
      D.h. also, der 2. Punkt: "Nachträglich kannst Du das ändern" muss also "immer" heissen.

      Den DNS Eintrag mußte ich nicht ändern.

      Trotzdem Danke, sonst hätte ich es nie gefunden.
    • DNS: Beim löschen eines DNS-Eintrags (CNAME)
      gibt es folgenden Fehler:

      domain.tld/client/dns_delete.php?edit_id=98


      EasySCP Exception Message

      SQLSTATE[HY093]: Invalid parameter number: number of bound variables does not match number of tokens


      (ca. 1 Std später):
      Sorry, aber ich stelle gerade fest, dass beim DNS-Eintrag ändern irgendwas in der PowerDNS.records zerschossen wurde. Hängt wohl direkt mit dem Fehler hierdrüber zusammen.
      Im Moment läuft auch postgrey nicht mehr - da bin ich aber noch am suchen

      The post was edited 1 time, last by kuerbis42 ().

    • kuerbis42 wrote:

      Im Moment läuft auch postgrey nicht mehr - da bin ich aber noch am suchen
      Ich habe da etwas ganz merkwürdiges gefunden:

      /etc/init.d/postgrey

      Source Code

      1. PIDFILE=/var/run/n/$DAEMON_NAME/$DAEMON_NAME.pid

      Laut original Postgrey-Script steht da aber:

      PIDFILE=/var/run/$DAEMON_NAME.pid


      Der Pfad /var/run/n existiert schon nicht....

      Nachdem ich wieder den "Originalzustand" hergestellt habe läuft auch Postgrey wieder.
    • kuerbis42 wrote:

      domain.tld/client/dns_delete.php?edit_id=98


      EasySCP Exception Message

      SQLSTATE[HY093]: Invalid parameter number: number of bound variables does not match number of tokens
      Ich glaube, ich habe den Fehler gefunden
      Über der Zeile 101 fehlt:

      Source Code

      1. $sql_param = array(
      2. 'record_id' => $_GET['edit_id'],
      3. );
      Das ist zwar schon einmal in Zeile 39 definiert, wird aber in Zeile 62, bzw. dann nochmal in 78 überschrieben

      Da ich nicht weiß wie EasySCP gepflegt wird (und ich es auch wenn ich es wüsste, nicht tun würde) überlasse ich es ShadowJumper ;)
    • kuerbis42 wrote:

      ShadowJumper wrote:

      Bzgl. dem externen Mail Server: Beim Anlegen des Kunden musst du die Mail Adressen auf "-1" setzen, dann wird Postfix auch nicht für diese Domain konfiguriert. Nachträglich kannst du das ändern, indem du zum einen die Mail Accounts und die Domain in der mail.domains bzw. mail.users löschst. Und dann noch im Lokalen DNS den MX Eintrag der Domain auf die tatsächliche IP des externen Servers umstellst. Dann passt das.
      Danke für den Tipp. Es hat geklappt aber:
      trotz "Mail Adressen = -1" legt EasySCP die Standartadressen "webmaster","abuse", und "postmaster" an und trägt die Domain auch in der Tabelle mail.domains ein.
      D.h. also, der 2. Punkt: "Nachträglich kannst Du das ändern" muss also "immer" heissen.

      Den DNS Eintrag mußte ich nicht ändern.

      Trotzdem Danke, sonst hätte ich es nie gefunden.

      Ich bin da mal die Sourcen durchgegangen, irgendwie ist es zwar so programmiert, wie Du es "bei Neuanlage" geschrieben hast, passieren tut es aber anders.

      Source Code: daemon/DaemonDomainCommon.php

      1. protected static function apacheWriteDomainConfig($domainData) {
      2. if ($domainData['domain_mailacc_limit'] == '-1'){
      3. DaemonMail::DaemonMailDeleteDomain($domainData['domain_name']);
      4. } else {
      5. DaemonMail::DaemonMailAddDomain($domainData['domain_name']);
      6. }
      7. .....
      Wenn man die Domain dann aber nochmal "anfasst", also auf Domain ändern geht und gleich weider speichert, dann greift das "Delete"



      Source Code: /gui/htdocs/reseller/user_add3.php

      1. // Create the 3 default addresses if wanted
      2. if ($cfg->CREATE_DEFAULT_EMAIL_ADDRESSES) {
      3. client_mail_add_default_accounts($dmn_id, $user_email, $dmn_name); // 'domain', 0
      4. }
      In das if() müsste noch && $mail>-1 dazu - ich hoffe $mail enthält hier den Wert der MaxMailAcc.
    • kuerbis42 wrote:

      Moin, URGENT!!

      Eben stelle ich fest, dass die Festpllate total voll ist...


      Die Backups laufen recursiv über INKLUSIVE dem Backup-Verzeichnis selbst!

      Ich glaube, dass ist wirklich dringend.

      Gruss, Kuerbis42
      Hi,

      das würde mich schon etwas wundern, weil unter anderem "--exclude=backups" gesetzt ist. Habe es gerade kontrolliert, bei mir werden die ausgeschlossenen Ordner nicht mit gesichert.
      Gruss
      Shadow