[GELÖST] CentOS 7 & php7.2 - Warnung: Deprecated: idn_to_ascii()

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • [GELÖST] CentOS 7 & php7.2 - Warnung: Deprecated: idn_to_ascii()

      Hi zusammen,

      ich habe ein CentOS 7 System hoch gezogen und php7.2 drauf gehauen.
      Nun bekomme ich folgende Fehlermeldung, wenn ich mich im AdminPanel einlogge bzw. das Admin Panel aufrufe:
      Deprecated: idn_to_ascii(): INTL_IDNA_VARIANT_2003 is deprecated in /var/www/easyscp/gui/include/easyscp-functions.php on line 397Deprecated: idn_to_ascii(): INTL_IDNA_VARIANT_2003 is deprecated in /var/www/easyscp/gui/include/easyscp-functions.php on line 397Deprecated: idn_to_ascii(): INTL_IDNA_VARIANT_2003 is deprecated in /var/www/easyscp/gui/include/easyscp-functions.php on line 397Deprecated: idn_to_ascii(): INTL_IDNA_VARIANT_2003 is deprecated in /var/www/easyscp/gui/include/easyscp-functions.php on line 397
      Hat jemand eine Idee? - Downgrade der PHP Version? ?(

      Danke & Gruß
      piccolo
    • Hi,

      das Problem sind aktuell Inkompatibilitäten. Mit 7.2 wird nochmals ein ganzer Schwung an Funktionen über Bord geworfen bzw. geändert.

      In diesem Fall ist es doppelt Fatal, da die IDN Konvertierung Auswirkungen darauf hat wie Domains mit Sonderzeichen/Umlauten behandelt werden.

      Peinlich für PHP bzw. Zend Technologies wird es aber dadurch das der PHP Aufruf ohne Parameter benutzt wird, sprich die Standard Einstellung unter PHP 7.2 ist hier bereits falsch. Die Default Einstellung unter PHP 7.2 ist hier "INTL_IDNA_VARIANT_2003", und gleichzeitig sagt PHP 7.2 das diese Einstellung veraltet ist und nicht mehr benutzt werden soll.

      Kommentiere die Zeilen 377 und 397 aus, und benutze stattdessen Zeile 378 bzw. 398. So sollte es nach neuer Norm korrekt sein.
      Gruss
      Shadow
    • Hi,

      wie gesagt, "Peinlich" ist ja nur das PHP 7.2 seine eigene Default Einstellung als "Falsch" betrachtet ;)

      Ich hatte das schon mal überarbeitet, aber wegen was anderem hatte ich das wieder zurück gebaut auf alten Stand. Ich bin mir aktuell nur nicht mehr sicher was es genau war.

      Muss mir das nochmal in Ruhe anschauen, bislang hatte ich selber nur eine Handvoll Domains die davon betroffen waren.
      Gruss
      Shadow