CONTAO CMS

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • One of my users wants to install the "contao" CMS on his sub-domain. This CMS requires that everything is installed in a sub directory "{webroot}/contao" and then the domain pointing has to be changed from "{webroot}" to "{webroot}/contao/web".

      I do know how to manually change the apache config for this web to point to the correct folder, but this won't last as the apache config is recreated from scratch everytime something is changed on a domain or sub domain.

      Is there some "regular" way to adjust the domain pointing for a certain web? All the docs state "open your PLESK panel and adjust the domain pointing" :(
      FTP root however has to stay at {webroot}..

      EasySCP 2.1.0
    • I didn't figure out when this change is applied. apache restart was not enough. I suppose "when any domain operation is done". I repeated this schange in the apache config and assume the former change will make sure it stays this way.

      ... but ...

      "contao" seems quite demanding how it wants to use the system. It assumes the user has shell access to utilize the "composer". This is necessary every time the user wants to add a new module, wants to install published fixes or a version update.

      There IS a php (indeed it's a .phar.php) "manager" that should allow the same tasks via browser interface, so I can circumvent the shell acess, but that one wants to utilize the command line PHP to do all this tasks in the background. Due to CHROOT it is of no help if I tell the script the correct path to PHP (/usr/bin/php), since the access is blocked anyway. So we can't get past the basic configuration page.

      Seems that "contao" is a no go with this configuration, or is there a way to grant access to the php executable from within the jail?

      The post was edited 1 time, last by smallfreak ().

    • Hi,

      on my systems, a apache reload is the only thing that is needed to make changes in this files working.

      About php: In the fact that the basic system is hardened about security, you need to edit the php.ini file of the domain. They all stay under "/var/www/fcgi/yourDomain/......." and then restart apache (reload does not work) to adopt the new configuration settings.
      Gruss
      Shadow